GeoFibra-Pro. Dependencias.

Las dependencias necesarias para GeoFibra-Pro son siquientes:

  • QGIS 2.18: QGIS será el software GIS marco en el que encajaremos nuestro trabajo.
  • PostgreSQL 9.5: Es el sistema gestor de la Base de Datos.
  • PostGIS 2.3.7: (Enlace a ejecutables de Windows) Es la extensión espacial Postgres. Con ella podremos disparar nuestras consultas con predicados espaciales.
  • Python 2.7: El lenguaje de programación con el que está escrito nuestro plugin.
  • Psycopg2: Estas son unas librerías que posibilitarán que Python se comunique con las BBDD de PostgreSQL. Se recomienda instalar a través de “pip”.
    • 1. Descargar el archivo get-pip.py
      2. Moverlo a la carpeta C:\Python27
      3. Abres cmd
      4. Cambias de directorio a la carpeta de Python. cd C:\Python27
      5. Ejecutas get-pip desde cmd con : python get-pip.py
      6. Una vez completada la instalación: cd Scripts
      7. instalamos psycopg2: pip install psycopg2